Delays in Processing of ACH By Partner Bank
Incident Report for Synapse
Monitoring
The issue now have been resolved and we are monitoring for any new escalations for the next few hours.
Posted Apr 26, 2024 - 08:03 PDT
Investigating
Synapse has been made aware of a processing delay by partner bank (Evolve Bank & Trust) for ACH Payments + Returns.

We are actively communicating with our partner and will provide details as they become available.
Posted Apr 25, 2024 - 10:54 PDT
This incident affects: Banking Service Providers.