[Card Issuance] Delayed interchange revenue disbursement
Incident Report for Synapse
Resolved
Interchange revenue disbursements were made over the weekend.
Posted 16 days ago. Sep 03, 2019 - 09:53 PDT
Monitoring
Interchange revenue disbursements for our card issuance product are due to be disbursed by the end of this week for payments due in August. Note that this is a delay in the normal payout time, as we are making enhancements to our revenue disbursement stack.
Posted 23 days ago. Aug 27, 2019 - 10:03 PDT