Delayed Webhook Delivery
Incident Report for Synapse
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 20:15 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 13, 2019 - 08:15 PST
Monitoring
Looks like the Redis issue that occurred last night (https://status.synapsefi.com/incidents/trk4vswt9x81) impacted webhook delivery for older payloads. Even when the issue was resolved, the compiled version of our webhooks microservice was still pointing to the old Redis cluster, resulting into delayed webhook delivery.

As of few minutes ago, the webhooks microservice was restarted which fixed the pointer issue. All new webhooks are getting delivered as expected.

Currently we are in the processes of delivering all the webhooks we missed from last night. Once that task is finished, we will update the status page.
Posted Nov 13, 2019 - 08:15 PST
This incident affected: CORE APIs.