[Helpdesk] Issue receiving emails to help@synapsefi.com
Incident Report for Synapse
Resolved
This incident has been resolved.
Posted Dec 20, 2019 - 16:48 PST
Identified
Currently we are working on resolving an issue where tickets emailed to help@synapsefi.com are not appearing in our helpdesk.

Until we get this resolved, please send email tickets to help@synapsepay.com
Posted Dec 20, 2019 - 12:19 PST